Межсайтовый скриптинг в BlackBoard Learning System

Дата публикации:
04.10.2007
Всего просмотров:
1119
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Blackboard Learning and Community Portal Systems 6
Blackboard Learning System 6
Уязвимые версии:
Blackboard Learning and Community Portal Systems 6.3.1.593, возможно более ранние версии
Blackboard Learning System 6.3.1.593, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "subject_t" и "body_text" в сценарии messaging/course/composeMessage.jsp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.blackboard.com

Решение: Установите последнюю версию Release 6 Application Pack 3 Service Pack 2 Hotfix 3 с сайта производителя.

или введите имя

CAPTCHA