PHP-инклюдинг в phpBB phpbb-openid

Дата публикации:
02.10.2007
Дата изменения:
02.10.2007
Всего просмотров:
21741
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpbb-openid (модуль к phpBB) 0.x
Уязвимые версии: phpbb-openid (модуль к phpBB) 0.2.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "openid_root_path" в сценарии includes/openid/Auth/OpenID/BBStore.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/includes/openid/Auth/OpenID/BBStore.php?openid_root_path=[file]

URL производителя: sourceforge.net/projects/phpbb-openid/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA