PHP-инклюдинг в IntegraMOD Portal

Дата публикации:
30.09.2007
Дата изменения:
13.09.2008
Всего просмотров:
7054
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IntegraMOD Portal 1.x
Уязвимые версии: IntegraMOD Portal 1.4.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "phpbb_root_path" в сценарии includes/archive/archive_topic.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/includes/archive/archive_topic.php?phpbb_root_path=[file]

URL производителя: www.integramod.nl/forum/portal.php

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://milw0rm.com/exploits/4463

или введите имя

CAPTCHA
30-09-2007 18:31:06
Методы всегда есть! Главное, чтоб руки не кривые были ))
0 |