Переполнение буфера в Ask Toolbar ToolbarSettings ActiveX компоненте

Дата публикации:
27.09.2007
Дата изменения:
27.02.2008
Всего просмотров:
2063
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ask Toolbar
Уязвимые версии: Ask Toolbar 4.0.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в AskJeevesToolBar.SettingsPlugin.1 ActiveX компоненте (askBar.dll) при обработке свойства "ShortFormat". Удаленный пользователь может с помощью специально сформированной Web страницы передать уязвимому свойству слишком длинную строку (более 500 байт), вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: dl.ask.com/toolbar

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: AskJeeves Toolbar 4.0.2.53 activex Remote Buffer Overflow Exploit

или введите имя

CAPTCHA