Переполнение буфера в Balsa

Дата публикации:
25.09.2007
Дата изменения:
25.09.2007
Всего просмотров:
1572
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Balsa 2.x
Уязвимые версии: Balsa версии до 2.3.20.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке команды "FETCH" в функции "ir_fetch_seq()" файла libbalsa/imap/imap-handle.c. Удаленный авторизованный пользователь может с помощью слишком длинного ответа команде FETCH вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: balsa.gnome.org

Решение: Установите последнюю версию 2.3.20 с сайта производителя.

или введите имя

CAPTCHA