Несколько уязвимостей в iziContents

Дата публикации:
25.09.2007
Дата изменения:
25.09.2007
Всего просмотров:
14276
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-5055
CVE-2007-5054
CVE-2007-5053
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
iziContents 1.x
Уязвимые версии: iziContents 1RC6, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "gsLanguage" в сценариях modules/search/search.php, modules/poll/inlinepoll.php, modules/poll/showpoll.php, modules/links/showlinks.php и modules/links/submit_links.php (когда параметр "language_home" не установлен и параметр "rootdp" установлен в произвольное значение). Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/modules/search/search.php?language_home=&rootdp=zZz&gsLanguage=[file]
http://[host]/modules/poll/inlinepoll.php?language_home=&rootdp=zZz&gsLanguage=[file]
http://[host]/modules/poll/showpoll.php?language_home=&rootdp=zZz&gsLanguage=[file]
http://[host]/modules/links/showlinks.php?language_home=&rootdp=zZz&gsLanguage=[file]
http://[host]/modules/links/submit_links.php?rootdp=zZz&gsLanguage=[file]

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "admin_home" в сценарии modules/poll/poll_summary.php (когда параметр "rootdp" установлен в произвольное значение) и в параметре "rootdp" в сценарии include/db.php. Удаленный пользователь может с помощью специально сформированного запроса просмотреть содержимое произвольных файлов на системе. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена и опция "magic_quotes_gpc" отключена в конфигурационном файле PHP. Пример:

http://[host]/modules/poll/poll_summary.php?rootdp=zZz&admin_home=/etc/passwd%00
http:// [host]/include/db.php?rootdp=/etc/passwd%00

URL производителя: www.izicontents.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA