Множественные уязвимости в CMS Made Simple

Дата публикации:
25.09.2007
Дата изменения:
02.12.2008
Всего просмотров:
4944
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-5056
CVE-2007-5441
CVE-2007-5442
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CMS Made Simple 1.x
Уязвимые версии: CMS Made Simple 1.1.3.1, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, обойти некоторые ограничения безопасности, получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "last_module" в сценарии lib/adodb_lite/adodb-perf-module.inc.php перед вызовом функции "eval()". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для успешной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[path]/lib/adodb_lite/adodb-perf-module.inc.php?last_module=zZz_ADOConnection{}eval($_GET[w]);class%20zZz_ADOConnection{}//&w=phpinfo();

2. Уязвимость существует из-за недостаточной обработки входных данных в тегах "anchor" и "listtag". Удаленный пользователь может с помощью специально сформированного запросы выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточного ограничения доступа к сценарию adduser.php. Удаленный пользователь может создать новые учетные записи в приложении.

4. Уязвимость существует из-за недостаточного ограничения доступа к административному журналу. Удаленный пользователь может получить доступ к потенциально важным данным.

URL производителя: www.cmsmadesimple.org

Решение: Установите последнюю версию 1.1.4.1 с сайта производителя.

Журнал изменений:

02.12.2008
Изменено описание уязвимостей.

Ссылки: http://milw0rm.com/exploits/4442
http://blog.cmsmadesimple.org/2007/10/07/announcing-cms-made-simple-1141/

или введите имя

CAPTCHA