PHP-инклюдинг в DFD Cart

Дата публикации:
25.09.2007
Дата изменения:
29.03.2009
Всего просмотров:
11757
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-5098
CVE-2007-5136
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DFD Cart 1.x
Уязвимые версии: DFD Cart 1.1.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "set_depth" в сценариях product.control.config.php, customer.area/customer.browse.list.php и customer.area/customer.browse.search.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/dfd_cart/app.lib/product.control/core.php/product.control.config.php?set_depth=[file]
http://[host]/dfd_cart/app.lib/product.control/core.php/customer.area/customer.browse.list.php?set_depth=[file] http://[host]/dfd_cart/app.lib/product.control/core.php/customer.area/customer.browse.search.php?set_depth=[file]

URL производителя: www.dragonfrugal.com/open.source/software/dfdcart/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
29.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA