PHP-инклюдинг в phpFFL

Дата публикации:
17.09.2007
Дата изменения:
18.09.2007
Всего просмотров:
8556
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-4934
CVE-2007-4935
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpFFL 1.x
Уязвимые версии: phpFFL 1.24, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "PHPFFL_FILE_ROOT" в сценариях program_files/livedraft/admin.php и program_files/livedraft/livedraft.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/phpffl/phpffl_webfiles/program_files/livedraft/livedraft.php?PHPFFL_FILE_ROOT=[file]
http://[host]/phpffl/phpffl_webfiles/program_files/livedraft/admin.php?PHPFFL_FILE_ROOT=[file]

URL производителя: www.phpffl.com

Решение: Установите последнюю версию 1.25 с сайта производителя.

или введите имя

CAPTCHA