Несколько уязвимостей в Invision Power Board

Дата публикации:
14.09.2007
Дата изменения:
14.09.2007
Всего просмотров:
5207
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-4912
CVE-2007-4914
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Invision Power Board 2.x
Уязвимые версии: Invision Power Board 2.3.1, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяет удаленному пользователю обойти некоторые ограничения безопасности и произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в полях форм в сценарии ips_kernel/class_ajax.php. Удаленный пользователь может с помощью специально сформированных данных, отображаемых на странице профиля, выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости приложение должно быть сконфигурировано на использование кодировок, отличных от "iso-8859-1" и "utf-8".

2. Уязвимость существует из-за ошибки в менеджере подписок при обработке платежей. Удаленный пользователь может с помощью специально сформированной формы платежа изменить идентификатор участника подписки. Удачная эксплуатация уязвимости позволит злоумышленнику отключить администраторов и модераторов от подписки.

URL производителя: www.invisionboard.com

Решение: Установите исправленную версию 2.3.1 или исправление с сайта производителя.

или введите имя

CAPTCHA