Межсайтовый скриптинг и SQL-инъекция в Wordpress

Дата публикации:
14.09.2007
Дата изменения:
14.09.2007
Всего просмотров:
3037
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-4893
CVE-2007-4894
CVE-2008-2146
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress 2.x
WordPress MU 1.x
Уязвимые версии:
Wordpress версии до 2.2.3
Wordpress MU версии до 1.2.5a

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных некоторых параметрах (например, в параметре "post_type" при обработке URL, который передается функции "pingback.extensions.getPingbacks()" метода XMLRPC). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Удаленный пользователь может получить привилегии "unfiltered_html" путем добавления поля "no_filter". Удаленный пользователь может с помощью специально сформированного запроса опубликовать произвольный HTML код в блоге.

URL производителя: wordpress.org

Решение: Установите последнюю версию с сайта производителя.

или введите имя

CAPTCHA