Множественные уязвимости в Claroline

Дата публикации:
07.09.2007
Дата изменения:
07.09.2007
Всего просмотров:
1693
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-4717
CVE-2007-4718
CVE-2007-4741
CVE-2007-4742
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Claroline 1.x
Уязвимые версии: Claroline версии до 1.8.6.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и получить доступ к важным данным на системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "sort" и "dir" в сценарии admin/adminusers.php, в параметре "action" в сценарии admin/advancedUserSearch.php и в параметре "view" в сценарии admin/campusProblem.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "language" в сценарии inc/lib/language.lib.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

URL производителя:

Решение: Установите последнюю версию 1.8.6 с сайта производителя.

или введите имя

CAPTCHA