Переполнение буфера в BitchX

Дата публикации:
28.08.2007
Дата изменения:
28.08.2007
Всего просмотров:
1606
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
BitchX 1.x
Уязвимые версии: BitchX 1.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке IRC MODE сообщений. Удаленный пользователь может послать уязвимому IRC клиенту специально сформированное MODE сообщение, содержащее слишком длинный параметр, вызвать переполнение буфера и выполнить произвольный код на целевой системе. Для успешной эксплуатации уязвимости целевой пользователь должен быть подключен к злонамеренному серверу.

URL производителя: www.bitchx.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: BitchX 1.1 Final MODE Remote Heap Overflow Exploit (0-day)

или введите имя

CAPTCHA