Несколько уязвимостей в ALPass

Дата публикации:
28.08.2007
Дата изменения:
28.08.2007
Всего просмотров:
1546
Опасность:
Средняя
Наличие исправления:
Частично
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-4549
CVE-2007-4550
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ALPass 2.x
ALPass (Korean) 3.x
Уязвимые версии: ALPass 2.72 (English) и 3.02 (Korean).

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных в функционале "Import Site Information" при декодировании ключа для ALPass DB File (APW) файла. Злоумышленник может с помощью специально сформированного APW файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Уязвимость форматной строки обнаружена при обработке путей файлов во время импорта данных из APW файла. Удаленный пользователь может с помощью специально сформированного APW файла выполнить произвольный код на целевой системе.

3. Уязвимость существует из-за ошибки при обработке данных о размере зашифрованных записей в APW файле. Удаленный пользователь может с помощью специально сформированного APW файла вызвать повреждение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.altools.net/ALTools/ALPass/tabid/56/Default.aspx

Решение: Установите последнюю версию 2.74 (English) с сайта производителя.

или введите имя

CAPTCHA