Межсайтовый скриптинг в MapServer

Дата публикации:
27.08.2007
Дата изменения:
27.08.2007
Всего просмотров:
1731
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-4542
CVE-2007-4629
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MapServer 4.x
Уязвимые версии: MapServer версии до 4.10.3.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в функции "processLine()" в файле maptemplate.c и в функции "writeError()" в файле mapserv.c. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: mapserver.gis.umn.edu

Решение: Установите последнюю версию 4.10.3 с сайта производителя.

или введите имя

CAPTCHA