Несколько уязвимостей в Ampache

Дата публикации:
21.08.2007
Всего просмотров:
1295
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-4437
CVE-2007-4438
Вектор эксплуатации:
Удаленная
Воздействие:
Внедрение в сессию пользователя
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ampache 3.x
Уязвимые версии: Ampache версии до 3.3.3.5

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти огранчиения безопасности и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "match" в сценарии albums.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за ошибки при обработке сессий. Злоумышленник может с помощью специально сформированной ссылки внедриться в сессию целевого пользователя.

URL производителя: www.ampache.org

Решение: Установите последнюю версию 3.3.3.5 с сайта производителя.

или введите имя

CAPTCHA