Переполнение буфера в Mercury Mail Transport System

Дата публикации:
21.08.2007
Дата изменения:
28.01.2008
Всего просмотров:
1443
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Mercury Mail Transport System 4.x
Уязвимые версии: Mercury Mail Transport System 4.51, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в Mercury/32 SMTP Server Module (mercurys.dll) при обработке аргументов команды AUTH CRAM-MD5. Удаленный пользователь может с помощью слишком длинного аргумента к команде вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.pmail.com/overviews/ovw_mercury.htm

Решение: Установите последнюю версию 4.52 с сайта производителя.

Журнал изменений:

28.01.2008
Изменена секция «Решение».

Ссылки: Mercury SMTPD Remote Preauth Stack Based Overrun PoC

или введите имя

CAPTCHA