Переполнение буфера в ESRI ArcSDE

Дата публикации:
16.08.2007
Всего просмотров:
1697
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ArcGIS 9.x
ESRI ArcSDE 8.x
ESRI ArcSDE 9.x
Уязвимые версии: ESRI ArcSDE 9.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в ArcSDE giomgr процессе. Удаленный пользователь может с помощью специально сформированного пакета, отправленного на порт 5151/tcp и содержащего цифровое значение в ASCII представлении длиной более 8 байт, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.esri.com

Решение: Установите последнюю версию ArcSDE 9.2 Service Pack 3 с сайта производителя.

или введите имя

CAPTCHA