PHP-инклюдинг в PHPCentral Poll

Дата публикации:
15.08.2007
Дата изменения:
15.08.2007
Всего просмотров:
1166
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHPCentral Poll
Уязвимые версии: PHPCentral Poll

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за некорректного использования функции "extract()" в сценарии functions.php. Удаленный пользователь может переписать некоторые переменные, установленные сервером. Злоумышленник может перезаписать параметр "_SERVER[DOCUMENT_ROOT]" в сценариях poll.php и pollarchive.php и выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

URL производителя: www.phpcentral.org/scripts.php?id=1

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA