Межсайтовый скриптинг в Drupal Content Construction Kit

Дата публикации:
14.08.2007
Дата изменения:
05.09.2008
Всего просмотров:
1281
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Content Construction Kit 5.x
Drupal Content Construction Kit 4.x
Уязвимые версии: Drupal Content Construction Kit версии до 4.7.x-1.6 и 5.x-1.6.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в модуле nodereference, когда поле nodereference просматривается через форматировщик "plain". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в модуле nodereference, когда поле nodereference редактируется с использованием виджета "autocomplete text field" без дополнительной опции "Views.module". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: drupal.org/project/cck

Решение: Установите последнюю версию 4.7.x-1.6 или 5.x-1.6 с сайта производителя.

или введите имя

CAPTCHA