Переполнение буфера в pfstools

Дата публикации:
10.08.2007
Всего просмотров:
937
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
pfstools 1.x
Уязвимые версии: pfstools 1.6.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в функции "readRadianceHeader()" в файле src/fileformat/rgbeio.cpp. Удаленный пользователь может с помощью специально сформированного Radiance RGBE (*.hdr) файла вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.mpi-inf.mpg.de/resources/pfstools/

Решение: Установите исправление из SVN репозитория с сайта производителя.

Ссылки: pfstools "readRadianceHeader()" Buffer Overflow Vulnerability

или введите имя

CAPTCHA