PHP-инклюдинг в Ncaster

Дата публикации:
10.08.2007
Всего просмотров:
6371
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ncaster 1.x
Уязвимые версии: Ncaster 1.7.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "adminfolder" в сценарии admin/addons/archive/archive.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/ncaster/admin/addons/archive/archive.php?adminfolder=[file]

URL производителя: www.ncastercms.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA