Межсайтовый скриптинг в WordPress

Дата публикации:
01.08.2007
Дата изменения:
10.04.2009
Всего просмотров:
1605
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress 2.x
Уязвимые версии: WordPress 2.2.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "style" в сценарии wp-admin/upload.php (когда параметр "post_id" установлен в отрицательное значение). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости злоумышленник должен иметь привилегии автора.

URL производителя: wordpress.org

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
10.04.2009
Изменена секция "Решение"

или введите имя

CAPTCHA