Раскрытие данных в PHP-Blogger

Дата публикации:
31.07.2007
Всего просмотров:
869
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP-Blogger 2.x
Уязвимые версии: PHP-Blogger 2.2.7, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к важным данным и обойти некоторые ограничения безопасности.

Уязвимость существует из-за того, что пароль администратора небезопасно хранится в data/pref.db. Удаленный пользователь может с помощью URL запроса получить MD5 хеш пароля администратора.

Примечание: также можно создать файл куки с параметром "key", равным хешу пароля администратора и получить административный доступ к приложению.

URL производителя: www.phpblogger.com

Решение: Закройте доступ к директории data с помощью .htaccess файла.

или введите имя

CAPTCHA