Множественные уязвимости в Bandersnatch

Дата публикации:
30.07.2007
Дата изменения:
26.11.2007
Всего просмотров:
910
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-3909
CVE-2007-3910
CVE-2007-6001
CVE-2007-5942
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Bandersnatch 0.x
Уязвимые версии: Bandersnatch 0.4, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "date", "func", "jid" и "limit" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки имен, сохраненных из Jabber. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.funkypenguin.co.za/forums/downloads.php?do=file&id=1

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA