Межсайтовый скриптинг в Drupal

Дата публикации:
27.07.2007
Всего просмотров:
2280
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-4063
CVE-2007-4064
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal 4.x
Drupal 5.x
Уязвимые версии: Drupal версии до 4.7.7 и 5.2.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости требуются привилегии "administer content types".

2. Уязвимость существует из-за некорректного использования Forms API и отсутствия проверки валидности запроса. Удаленный пользователь может с помощью специально сформированной ссылки произвести CSRF атаку.

URL производителя: drupal.org

Решение: Установите последнюю версию 4.7.7 или 5.2 с сайта производителя.

или введите имя

CAPTCHA