Переполнение буфера в Yahoo! Widgets YDP ActiveX кмопоненте

Дата публикации:
27.07.2007
Дата изменения:
27.02.2008
Всего просмотров:
1778
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Yahoo Widgets
Уязвимые версии: Yahoo! Widgets 4.0.3 (build 178), возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в YDPCTL.YDPControl.1 (YDPCTL.dll) ActiveX компоненте при обработке метода "GetComponentVersion()". Удаленный пользователь может с помощью специально сформированного Web сайта передать уязвимому методу слишком длинную строку (более 512 байт), вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: widgets.yahoo.com/download/

Решение: Установите последнюю версию 4.0.5 с сайта производителя.

или введите имя

CAPTCHA