Множественные уязвимости в fsplib

Дата публикации:
25.07.2007
Всего просмотров:
1746
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-3961
CVE-2007-3962
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
fsplib 0.x
Уязвимые версии: fsplib версии до 0.9.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных при обработке имен файлов в fsp_readdir_native. Удаленный пользователь может с помощью слишком длинного имени файла (более 26 символов) вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных при обработке содержимого директорий в fsp_readdir. Удаленный пользователь может вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: sourceforge.net/project/showfiles.php?group_id=93841&package_id=139615

Решение: Установите последнюю версию 0.9 с сайта производителя.

или введите имя

CAPTCHA