Переполнение буфера в Progress

Дата публикации:
13.07.2007
Дата изменения:
13.07.2007
Всего просмотров:
916
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Progress 9.x
Progress OpenEdge 10.x
Уязвимые версии:
Progress 9.1E
Progress OpenEdge 10.1x
RSA Authentication Manager 6.0, 6.1
RSA ACE/Server 5.2
RSA SecurID Applicance 2.0

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в Progress сервере (_mprosrv.exe). Удаленный пользователь может послать специально сформированный пакет на порт 5520/TCP или 5530/TCP, вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.progress.com

Решение: Установите исправление с сайта производителя.

Ссылки: Multiple Vendor Progress Server Heap Overflow Vulnerability

или введите имя

CAPTCHA