Несколько уязвимостей в CodeIgniter

Дата публикации:
12.07.2007
Всего просмотров:
3422
Опасность:
Средняя
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-3706
CVE-2007-3707
CVE-2007-3708
CVE-2007-3709
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CodeIgniter 1.x
Уязвимые версии: CodeIgniter 1.5.3, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и получить доступ к важным данным на системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "c" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для успешной эксплуатации уязвимости опция "enable_query_strings" должна быть включена.

2. Уязвимость существует из-за недостаточной обработки водных данных в функции xss_clean(). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.codeigniter.com

Решение: Установите исправление из SVN репозитория производителя.

или введите имя

CAPTCHA