Межсайтовый скриптинг в Moodle

Дата публикации:
06.07.2007
Дата изменения:
29.12.2008
Всего просмотров:
1083
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Moodle 1.7.x
Moodle 1.8.x
Уязвимые версии:
Moodle 1.7.1 и более ранние версии.
Moodle 1.8.1 и более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "search" в сценарии user/index.php (когда параметр "id" установлен в валидное значение). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: moodle.org

Решение: Установите последнюю версию 1.8.2 с сайта производителя.

Журнал изменений:

29.12.2008
Изменено описание уязвимостей.

или введите имя

CAPTCHA