Небезопасное создание временных файлов в GSAMBAD

Дата публикации:
04.07.2007
Всего просмотров:
783
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Debian GNU/Linux unstable alias sid
Debian GNU/Linux 4.0
Уязвимые версии: GSAMBAD 0.x

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за того, что функция "populate_conns()" в файле src/populate_conns.c создает небезопасным образом временные файлы. Злоумышленник может с помощью специально сформированной символической ссылки перезаписать произвольные файлы на системе с привилегиями пользователя, запустившего приложение (обычно root).

URL производителя: 85.214.17.244/gadmintools/index.php?option=com_content&task=view&id=16&Itemid=30

Решение: Установите последнюю версию с сайта производителя.

или введите имя

CAPTCHA