Межсайтовый скриптинг в продуктах SAP

Дата публикации:
02.07.2007
Дата изменения:
10.02.2009
Всего просмотров:
907
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-3495
CVE-2007-3496
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SAP NetWeaver 4.x
SAP Internet Communication Framework
Уязвимые версии:
SAP Internet Communication Framework
SAP NetWeaver 4.x

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в заголовке User-Agent в компоненте Web Dynpro Java в SAP Netweaver. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за ошибки при обработке входных данных на странице входы в компоненте SAP Basis в SAP Internet Communication Framework. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.sap.com

Решение: Установите исправление с сайта производителя.

Ссылки: http://www.csnc.ch/advisory/sap01.html
http://www.csnc.ch/advisory/sap02.html

или введите имя

CAPTCHA