PHP-инклюдинг в EVA-Web

Дата публикации:
02.07.2007
Дата изменения:
02.07.2007
Всего просмотров:
1003
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
EVA-Web 2.x
EVA-Web 1.x
Уязвимые версии: EVA-Web 2.3 и другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "aide" и "perso" в сценарии eva/index.php3. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/eva/index.php3?aide=[file]
http://[host]/eva/index.php3?perso=[file]

URL производителя: spip-edu.edres74.net/rubrique.php3?id_rubrique=22

Решение: Установите последнюю версию 2.3p1 с сайта производителя.

или введите имя

CAPTCHA