Межсайтовый скриптинг и SQL-инъекция в Calendarix

Дата публикации:
26.06.2007
Дата изменения:
28.02.2009
Всего просмотров:
1886
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-3183
CVE-2007-3182
CVE-2007-3259
CVE-2007-3258
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Calendarix Basic 0.x
Уязвимые версии: Calendarix Basic 0.7 20070307, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "month" и "year" в сценарии calendar.php и в параметре "search" в сценарии cal_search.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "month" и "year" в сценарии calendar.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.calendarix.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA