Отказ в обслуживании в Avahi

Дата публикации:
25.06.2007
Дата изменения:
19.12.2008
Всего просмотров:
1008
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Avahi 0.x
Уязвимые версии: Avahi версии до 0.6.20.

Описание:
Уязвимость позволяет локальному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки в функции "assert()" при получении пустых TXT данных через D-Bus для регистрации. Локальный пользователь может аварийно завершить работу демона.

URL производителя: avahi.org

Решение: Установите последнюю версию 0.6.20 с сайта производителя.

Ссылки: http://avahi.org/milestone/Avahi%200.6.20
http://avahi.org/changeset/1482

или введите имя

CAPTCHA