Межсайтовый скриптинг в Apache Tomcat

Дата публикации:
19.06.2007
Дата изменения:
15.08.2008
Всего просмотров:
2520
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache Tomcat 4.x
Apache Tomcat 5.x
Apache Tomcat 6.x
Уязвимые версии: Apache Tomcat 6.0.5 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в HTTP заголовке "Accept-Language". Удаленный пользователь может с помощью специально сформированного запроса (используя Flash файл) выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: tomcat.apache.org

Решение: Установите последнюю версию 4.1.36, 5.5.21, 5.0.HEAD или 6.0.6 с сайта производителя.

или введите имя

CAPTCHA