Межсайтовый скриптинг в Apache MyFaces Tomahawk

Дата публикации:
15.06.2007
Всего просмотров:
983
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache MyFaces Tomahawk 1.x
Уязвимые версии: Apache MyFaces Tomahawk 1.1.5, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "autoscroll". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: myfaces.apache.org/tomahawk/

Решение: Установите последнюю версию 1.1.6 с сайта производителя.

Ссылки: Apache MyFaces Tomahawk JSF Framework Cross-Site Scripting (XSS) Vulnerability

или введите имя

CAPTCHA