PHP-инклюдинг в Xoops Horoscope

Дата публикации:
14.06.2007
Дата изменения:
14.06.2007
Всего просмотров:
885
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Horoscope 2.x (модуль к Xoops)
Уязвимые версии: Horoscope (модуль к Xoops) 2.00, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "xoopsConfig[root_path]" в сценарии footer.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/modules/horoscope/footer.php?xoopsConfig[root_path]=[file]

URL производителя: www.xoops.org/modules/repository/singlefile.php?cid=32&lid=1162

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA