Переполнение буфера в OpenOffice

Дата публикации:
14.06.2007
Дата изменения:
14.06.2007
Всего просмотров:
2293
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-0245
CVE-2007-2754
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenOffice 1.1.x
OpenOffice 1.0.x
OpenOffice.org 2.x
Уязвимые версии:
OpenOffice 1.1.x
OpenOffice.org 2.x
OpenOffice 1.0.x

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки при обработке тега "prdata" в RTF файлах, в которых первый токен меньше второго. Удаленный пользователь может с помощью специально сформированного RTF файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за использования копии уязвимой библиотеки FreeType. Удаленный пользователь может с помощью специально сформированного документа вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.openoffice.org

Решение: Установите последнюю версию 2.2.1 с сайта производителя.

Ссылки: [DSA 1307-1] New OpenOffice.org packages fix arbitrary code execution

или введите имя

CAPTCHA