Несколько уязвимостей в e-Vision CMS

Дата публикации:
11.06.2007
Всего просмотров:
782
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-3214
CVE-2007-3251
CVE-2008-0856
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
e-Vision CMS 2.x
Уязвимые версии: e-Vision CMS 2.0.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к важным данным и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "img" в сценарии admin/show_img.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре файла куки "adminlang" в сценарии admin/functions.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "template" в сценарии style.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

URL производителя: sourceforge.net/projects/e-vision/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA