PHP-инклюдинг в Geeklog CAPTCHA Plugin

Дата публикации:
31.05.2007
Всего просмотров:
970
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CAPTCHA 2.x (plugin for Geeklog)
Уязвимые версии: CAPTCHA (плагин к Geeklog) 2.1.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "_CONF[path]" в сценарии class/captcha.class.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.gllabs.org/wiki/doku.php?id=geeklog:plugins:captcha

Решение: Установите последнюю версию 2.1.2 с сайта производителя.

или введите имя

CAPTCHA