Переполнение буфера в Sun Java System Web Proxy Server

Дата публикации:
31.05.2007
Всего просмотров:
1240
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Sun Java System Web Proxy Server 3.x
Sun Java System Web Proxy Server 4.x
Уязвимые версии: Sun Java System Web Proxy Server 4.0.4 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в SOCKS модуле. Удаленный пользователь может отправить SOCKS серверу специально сформированные пакеты, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.sun.com

Решение: Установите последнюю версию 4.0.5 или выше с сайта производителя.

Ссылки: Sun Java System Web Proxy Multiple Buffer Overflow Vulnerabilities
Security Vulnerabilities in the SOCKS Module of Sun Java System Web Proxy Server 4.0

или введите имя

CAPTCHA