Межсайтовый скриптинг в phpPgAdmin

Дата публикации:
31.05.2007
Дата изменения:
09.12.2008
Всего просмотров:
925
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-2865
CVE-2007-5728
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpPgAdmin 3.x
phpPgAdmin 4.x
Уязвимые версии: phpPgAdmin 4.1.1 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в различных сценариях (например, redirect.php, sqledit.php). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: phppgadmin.sourceforge.net

Решение: Установите последнюю версию 4.1.3 с сайта производителя.

Ссылки: http://lists.grok.org.uk/pipermail/full-disclosure/2007-May/063617.html

или введите имя

CAPTCHA