Уязвимость при обработке PNG изображений в PHP

Дата публикации:
22.05.2007
Всего просмотров:
1671
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 4.3.x
PHP 5.0.x
PHP 4.4.x
PHP 5.1.x
PHP 5.2.x
Уязвимые версии: PHP 4.4.7 и 5.2.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за некорректного использования библиотеки libpng в функции "gdPngReadData()" файла ext/gd/libgd/gd_png.c в GD расширении. Удаленный пользователь может с помощью специально сформированного PNG изображения вызвать зацикливание приложения.

URL производителя: www.php.net

Решение: Установите исправление из CVS репозитория производителя. viewcvs.php.net/viewvc.cgi/gd/libgd/gd_png.c?r1=1.22&r2=1.23&pathrev=HEAD

или введите имя

CAPTCHA