Переполнение буфера в PrecisionID Linear Barcode ActiveX компоненте

Дата публикации:
21.05.2007
Дата изменения:
27.02.2008
Всего просмотров:
1033
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PrecisionID Linear Barcode ActiveX Control 1.x
Уязвимые версии: PrecisionID Linear Barcode ActiveX Control 1.9.0.0, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в PrecisionID.BarCode.1 ActiveX компоненте (PrecisionID_Barcode.dll) при обработке метода "SaveBarCode()". Удаленный пользователь может с помощью специально сформированной Web страницы передать слишком длинный аргумент уязвимому методу, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.precisionid.com/index.asp?PageAction=ViewProd&ProdID=13

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: PrecisionID Barcode ActiveX 1.9 Remote Denial of Service Exploit
PrecisionID Barcode ActiveX 1.9 Remote Arbitrary File Overwrite Exploit

или введите имя

CAPTCHA