Несколько уязвимостей в Sun Java JDK

Дата публикации:
20.05.2007
Дата изменения:
03.09.2007
Всего просмотров:
1494
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-2788
CVE-2007-2789
CVE-2007-3004
CVE-2007-3005
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Sun Java JRE 1.3.x
Sun Java JRE 1.4.x
Sun Java SDK 1.3.x
Sun Java SDK 1.4.x
Sun Java JRE 1.5.x / 5.x
Sun Java JDK 1.5.x
Sun Java JRE 1.6.x / 6.x
Уязвимые версии: Sun Java JDK 1.5.0_07-b03, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

1. Целочисленное переполнение обнаружено в обработчике встроенных ICC профилей JPG и BMP изображений. Злоумышленник может с помощью специально сформированного изображения аварийно завершить работу JVM или выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за того, что обработчик BMP файлов пытается открыть локальные файлы ("/dev/tty") во время обработки BMP изображений. Удаленный пользователь может с помощью специально сформированного BMP файла вызвать отказ в обслуживании приложения.

URL производителя: java.sun.com/j2se/

Решение: Установите последнюю версию JDK 1.5.0_07-b03 или 1.6.0_01-b06 с сайта производителя.

Ссылки: Security Vulnerabilities in the Java Runtime Environment Image Parsing Code May Allow a Untrusted Applet to Elevate Privileges

или введите имя

CAPTCHA