Переполнение буфера в VCDGear

Дата публикации:
18.05.2007
Всего просмотров:
1016
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
VCDGear 3.x
Уязвимые версии: VCDGear 3.55, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных при обработке .CUE файлов. Удаленный пользователь может с помощью специально сформированного .CUE файла, содержащего слишком длинный тег, вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных при обработке информации "TRACK" в файлах .CUE. Удаленный пользователь может с помощью специально сформированного .CUE файла, содержащего слишком длинный тип "TRACK", вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.vcdgear.com

Решение: Установите последнюю версию с сайта производителя.

Ссылки: VCDGear Cue File Parsing Buffer Overflow Vulnerabilities

или введите имя

CAPTCHA