Множественные уязвимости в Little cms

Дата публикации:
17.05.2007
Дата изменения:
03.04.2009
Всего просмотров:
1040
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2007-2741
CVE-2008-5316
CVE-2008-5317
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Little cms 1.x
Удаленный пользователь может скомпрометировать целевую систему. Уязвимые версии: Little cms версии до 1.17

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки при обработке ICC профилей. Удаленный пользователь может с помощью злонамеренного JPG изображения, содержащего специально сформированный ICC профиль, вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за ошибки проверки границ данных в функции "ReadEmbeddedTextTag()" в файле src/cmsio1.c. Удаленный пользователь может вызвать переполнение буфера и выполнить произвольный код на целевой системе. Уязвимость исправлена в версии 1.16.

3. Целочисленное переполнение обнаружено в функции "cmsAllocGamma()" в файле src/cmsgamma.c. Удаленный пользователь может вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе. Уязвимость исправлена в версии 1.17.

URL производителя: www.littlecms.com

Решение: Установите последнюю версию 1.17 с сайта производителя.

Журнал изменений:

03.04.2009
Добавлены уязвимости #2-3, изменена секция «Решение».

Ссылки: http://scary.beasts.org/security/CESA-2007-001.html
http://www.openwall.com/lists/oss-security/2008/11/28/3

или введите имя

CAPTCHA