PHP-инклюдинг в YAAP

Дата публикации:
16.05.2007
Всего просмотров:
1856
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
YAAP 1.x
Уязвимые версии: YAAP 1.5 , возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "root_path" в сценарии includes/common.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http:[host]/[path]/includes/common.php?root_path=[file]

URL производителя: yaap.oskbraniewo.pl

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA